java.lang.RuntimeException: java.io.IOException: invalid constant type: 18



项目启动报错:

java.lang.RuntimeException: java.io.IOException: invalid constant type: 18




原因:jar包的版本1.7的不支持在1.8的JDK上运行

这个包如果是3.15之前的应该是不支持1.8的,可以换到更新的版本

升级javassist的版本,如

<!-- https://mvnrepository.com/artifact/org.javassist/javassist -->
<dependency>
    <groupId>org.javassist</groupId>
    <artifactId>javassist</artifactId>
    <version>3.21.0-GA</version>
</dependency>














javassist

2020.11.18 21:04

https://www.meihaocloud.com.com/190.html , 欢迎转载,请在文章页标出原文连接 !


Copyright © 2020 千夕网 联系站长

粤公网安备 44030302001408号 粤ICP备19099833号-1