error the @annotation pointcut expression is only supported at Java 5 compliance level or above



项目启动时报错:

error the @annotation pointcut expression is only supported at Java 5 compliance level  or above


这句话的意思是@annotation切点表达式仅支持 Java5或者以上版本。但是机器上装的是jdk1.8,在网上终于找到了问题所在


系统jar包aspectjweaver是1.6.2的,应该是AspectJ中的类型会判断Java版本,但是它不认识jdk8...所以我下了个aspectjweaver-1.9.4.jar,配置了一下果然成功了。即升级aspectjweaver的版本即可解决报错。






aspectjweaver

2020.11.18 21:04

https://www.meihaocloud.com.com/191.html , 欢迎转载,请在文章页标出原文连接 !


Copyright © 2020 千夕网 联系站长

粤公网安备 44030302001408号 粤ICP备19099833号-1